isomaster-1.3.13.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils fdo-mime toolchain-funcs
  5. DESCRIPTION="Graphical CD image editor for reading, modifying and writing ISO images"
  6. HOMEPAGE="http://littlesvr.ca/isomaster"
  7. SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~x86-fbsd"
  11. IUSE="nls"
  12. RDEPEND=">=dev-libs/iniparser-3.0.0:0
  13. x11-libs/gtk+:2"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig
  16. nls? ( >=sys-devel/gettext-0.19.1 )" # bug 512448
  17. pkg_setup() {
  18. myisoconf=(
  19. DEFAULT_EDITOR=leafpad
  20. MYDOCPATH=/usr/share/doc/${PF}/bkisofs
  21. USE_SYSTEM_INIPARSER=1
  22. PREFIX=/usr
  23. )
  24. use nls || myisoconf+=( WITHOUT_NLS=1 )
  25. }
  26. src_prepare() {
  27. epatch "${FILESDIR}"/${PN}-1.3.9-iniparser-3.0.0.patch #399629
  28. rm -R iniparser-2.17 || die
  29. }
  30. src_configure() { :; } #274361
  31. src_compile() {
  32. tc-export CC
  33. emake "${myisoconf[@]}"
  34. }
  35. _apply_linguas() {
  36. mv "${D}"/usr/share/locale{,_ALL} || die
  37. dodir /usr/share/locale || die
  38. for lingua in ${LINGUAS}; do
  39. [[ -d "${D}"/usr/share/locale_ALL/${lingua} ]] || break
  40. mv "${D}"/usr/share/{locale_ALL/${lingua},locale/} || die
  41. done
  42. rm -R "${D}"/usr/share/locale_ALL || die
  43. }
  44. src_install() {
  45. emake "${myisoconf[@]}" DESTDIR="${D}" install
  46. dodoc {CHANGELOG,CREDITS,README,TODO}.TXT *.txt
  47. use nls && _apply_linguas # bug 402679, bug 512448
  48. }
  49. pkg_postinst() {
  50. fdo-mime_desktop_database_update
  51. }
  52. pkg_postrm() {
  53. fdo-mime_desktop_database_update
  54. }