mode2cdmaker-1.5.1.ebuild 619 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="Utility to create mode-2 CDs, for example XCDs"
  5. HOMEPAGE="https://www.gentoo.org/"
  6. SRC_URI="mirror://gentoo/${P}-src.zip"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc ~x86"
  10. IUSE=""
  11. DEPEND="app-arch/unzip"
  12. RDEPEND=""
  13. S=${WORKDIR}
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. epatch "${FILESDIR}"/${P}-gentoo.patch
  18. }
  19. src_compile() {
  20. tc-export CC
  21. emake -f Makefile.linux || die
  22. }
  23. src_install() {
  24. dobin mode2cdmaker || die
  25. dodoc {bugs,compatibility,readme}.txt
  26. }