uif2iso-0.1.7c.ebuild 697 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="Converts MagicISO CD-images to iso"
  5. HOMEPAGE="http://aluigi.org/mytoolz.htm#uif2iso"
  6. SRC_URI="mirror://gentoo/${P}.zip"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE=""
  11. RDEPEND="sys-libs/zlib"
  12. DEPEND="${RDEPEND}
  13. app-arch/unzip"
  14. S="${WORKDIR}/src"
  15. src_compile() {
  16. # Yes we use our own makefile, I'll try to explain this to
  17. # upstream _again_.
  18. emake CC="$(tc-getCC)" -f "${FILESDIR}/0.1.7-Makefile" || die "emake failed"
  19. }
  20. src_install() {
  21. dobin ${PN} || die "failed to install"
  22. dodoc "${WORKDIR}"/${PN}.txt "${WORKDIR}"/README
  23. }