bluefish-2.2.6.ebuild 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils fdo-mime python-single-r1
  6. MY_P=${P/_/-}
  7. DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer"
  8. SRC_URI="http://www.bennewitz.com/bluefish/stable/source/${MY_P}.tar.bz2"
  9. HOMEPAGE="http://bluefish.openoffice.nl/"
  10. LICENSE="GPL-2"
  11. KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
  12. SLOT="0"
  13. IUSE="nls python spell"
  14. RDEPEND="
  15. x11-libs/gtk+:3
  16. gnome-extra/gucharmap:2.90
  17. sys-libs/zlib
  18. python? ( ${PYTHON_DEPS} )
  19. spell? ( app-text/enchant )"
  20. DEPEND="${RDEPEND}
  21. >=dev-libs/glib-2.16:2
  22. dev-libs/libxml2:2
  23. virtual/pkgconfig
  24. x11-libs/pango
  25. nls? (
  26. sys-devel/gettext
  27. dev-util/intltool
  28. )"
  29. S=${WORKDIR}/${MY_P}
  30. # there actually is just some broken manpage checkup -> not bother
  31. RESTRICT="test"
  32. pkg_setup() {
  33. use python && python-single-r1_pkg_setup
  34. }
  35. # Never eautoreconf this package as gettext breaks completely (no translations
  36. # even if it compiles afterwards)!
  37. src_configure() {
  38. econf \
  39. --docdir="${EPREFIX}/usr/share/doc/${PF}" \
  40. --disable-dependency-tracking \
  41. --disable-update-databases \
  42. --disable-xml-catalog-update \
  43. $(use_enable nls) \
  44. $(use_enable spell spell-check) \
  45. $(use_enable python)
  46. }
  47. src_install() {
  48. default
  49. find "${ED}" -name '*.la' -exec rm -f {} +
  50. }
  51. pkg_postinst() {
  52. fdo-mime_desktop_database_update
  53. fdo-mime_mime_database_update
  54. einfo "Adding XML catalog entries..."
  55. /usr/bin/xmlcatalog --noout \
  56. --add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
  57. --add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
  58. --add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
  59. /etc/xml/catalog \
  60. || ewarn "Failed to add XML catalog entries."
  61. }
  62. pkg_postrm() {
  63. fdo-mime_desktop_database_update
  64. fdo-mime_mime_database_update
  65. einfo "Removing XML catalog entries..."
  66. /usr/bin/xmlcatalog --noout \
  67. --del 'Bluefish/DTD/Bflang' \
  68. --del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
  69. --del 'http://bluefish.openoffice.nl/DTD' \
  70. /etc/xml/catalog \
  71. || ewarn "Failed to remove XML catalog entries."
  72. }