123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- PYTHON_COMPAT=( python2_7 )
- inherit autotools eutils fdo-mime python-single-r1
- MY_P=${P/_/-}
- DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer"
- SRC_URI="http://www.bennewitz.com/bluefish/stable/source/${MY_P}.tar.bz2"
- HOMEPAGE="http://bluefish.openoffice.nl/"
- LICENSE="GPL-2"
- KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- SLOT="0"
- IUSE="+gtk3 gucharmap nls python spell"
- RDEPEND="
- gnome-extra/gucharmap:2.90
- sys-libs/zlib
- !gtk3? ( x11-libs/gtk+:2 )
- gtk3? (
- x11-libs/gtk+:3
- gucharmap? ( gnome-extra/gucharmap:2.90 )
- )
- python? ( ${PYTHON_DEPS} )
- spell? ( app-text/enchant )"
- DEPEND="${RDEPEND}
- dev-libs/libxml2:2
- >=dev-libs/glib-2.24:2
- virtual/pkgconfig
- x11-libs/pango
- nls? (
- sys-devel/gettext
- dev-util/intltool
- )"
- S="${WORKDIR}/${MY_P}"
- # there actually is just some broken manpage checkup -> not bother
- RESTRICT="test"
- pkg_setup() {
- if ! use gtk3 && use gucharmap ; then
- ewarn "gucharmap USE flag requires the gtk3 USE flag being enabled."
- ewarn "Disabling charmap plugin."
- fi
- use python && python-single-r1_pkg_setup
- }
- PATCHES=(
- "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch"
- )
- # eautoreconf seems to no longer kill translation files.
- src_prepare() {
- default
- eautoreconf
- sed -i 's:gzip -n $< -c:gzip -n -c $<:' data/bflib/Makefile.* || die "Cannot fix makefile"
- }
- src_configure() {
- econf \
- --disable-dependency-tracking \
- --disable-update-databases \
- --disable-xml-catalog-update \
- $(use_with !gtk3 gtk2) \
- $(usex gtk3 "$(use_with gucharmap charmap)" '--without-charmap') \
- $(use_enable nls) \
- $(use_enable spell spell-check) \
- $(use_enable python)
- }
- src_install() {
- default
- prune_libtool_files
- }
- pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- einfo "Adding XML catalog entries..."
- /usr/bin/xmlcatalog --noout \
- --add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
- --add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
- --add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
- /etc/xml/catalog \
- || ewarn "Failed to add XML catalog entries."
- }
- pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- einfo "Removing XML catalog entries..."
- /usr/bin/xmlcatalog --noout \
- --del 'Bluefish/DTD/Bflang' \
- --del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
- --del 'http://bluefish.openoffice.nl/DTD' \
- /etc/xml/catalog \
- || ewarn "Failed to remove XML catalog entries."
- }
|