dav-0.8.5-r2.ebuild 907 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="A minimal console text editor"
  6. HOMEPAGE="http://dav-text.sourceforge.net/"
  7. # The maintainer does not keep sourceforge's mirrors up-to-date,
  8. # so we point to the website's store of files.
  9. SRC_URI="http://dav-text.sourceforge.net/files/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
  13. RDEPEND="sys-libs/ncurses:0"
  14. DEPEND="
  15. ${RDEPEND}
  16. virtual/pkgconfig
  17. "
  18. PATCHES=(
  19. "${FILESDIR}/${P}-asneeded.patch"
  20. "${FILESDIR}/${P}-davrc-buffer-overflow.patch"
  21. "${FILESDIR}/fix-Wformat-security-warnings.patch"
  22. )
  23. # Makefile only
  24. src_configure() { :; }
  25. src_compile() {
  26. emake \
  27. CC="$(tc-getCC)" \
  28. CFLAGS="${CFLAGS}" \
  29. LDFLAGS="${LDFLAGS} $( $(tc-getPKG_CONFIG) --libs ncurses)"
  30. }
  31. DOCS=( README )