ee-1.4.6.ebuild 765 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit toolchain-funcs
  5. DESCRIPTION="An easy to use text editor. Intended to be usable with little or no instruction"
  6. HOMEPAGE="http://mahon.cwx.net/"
  7. SRC_URI="http://mahon.cwx.net/sources/${P}.src.tgz"
  8. LICENSE="Artistic"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
  11. IUSE=""
  12. RDEPEND="!app-editors/ersatz-emacs"
  13. S="${WORKDIR}/easyedit-${PV}"
  14. src_prepare() {
  15. sed -i \
  16. -e "s/\tcc /\t\\\\\$(CC) /" \
  17. -e "/other_cflag/s/ *-s//" \
  18. create.make
  19. }
  20. src_configure() {
  21. emake localmake
  22. }
  23. src_compile() {
  24. emake -f make.local CC="$(tc-getCC)"
  25. }
  26. src_install() {
  27. dobin ee
  28. doman ee.1
  29. dodoc Changes README.ee ee.i18n.guide ee.msg
  30. }