ersatz-emacs-20060515.ebuild 998 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="A very minimal imitation of the famous GNU Emacs editor"
  6. HOMEPAGE="http://hunter.apana.org.au/~cjb/Code/"
  7. # taken from http://hunter.apana.org.au/~cjb/Code/ersatz.tar.gz
  8. SRC_URI="mirror://gentoo/${P}.tar.gz"
  9. LICENSE="public-domain"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. RDEPEND="!app-editors/ee
  13. sys-libs/ncurses"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig"
  16. S="${WORKDIR}"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-gentoo.patch
  19. sed -i -e "s%/usr/local/share/%/usr/share/doc/${PF}/%" ee.1 \
  20. || die "sed failed"
  21. }
  22. src_compile() {
  23. emake CC="$(tc-getCC)" \
  24. CFLAGS="${CFLAGS} -Wall" \
  25. LFLAGS="${LDFLAGS} $("$(tc-getPKG_CONFIG)" --libs ncurses)"
  26. }
  27. src_install() {
  28. # Note: /usr/bin/ee is "easy edit" on FreeBSD, so if this
  29. # is ever keyworded *-fbsd the binary has to be renamed.
  30. dobin ee
  31. doman ee.1
  32. dodoc ChangeLog ERSATZ.keys README
  33. }