hexedit-1.2.13.ebuild 698 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="View and edit files in hex or ASCII"
  6. HOMEPAGE="http://rigaux.org/hexedit.html"
  7. SRC_URI="http://rigaux.org/${P}.src.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~arm64 hppa ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
  11. DEPEND="sys-libs/ncurses:="
  12. RDEPEND="${DEPEND}"
  13. S=${WORKDIR}/${PN}
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
  16. mv configure.in configure.ac || die
  17. eautoreconf
  18. }
  19. src_install() {
  20. dobin hexedit
  21. doman hexedit.1
  22. dodoc Changes
  23. }