jupp-3.1_p30.ebuild 655 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="portable version of JOE's Own Editor"
  5. HOMEPAGE="https://www.mirbsd.org/jupp.htm"
  6. SRC_URI="https://www.mirbsd.org/MirOS/dist/${PN}/joe-${PV/_p/${PN}}.tgz"
  7. LICENSE="GPL-1"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="ncurses"
  11. RDEPEND="ncurses? ( sys-libs/ncurses:0= )
  12. !app-editors/joe"
  13. DEPEND="${RDEPEND}"
  14. S=${WORKDIR}/${PN}
  15. src_prepare() {
  16. default
  17. chmod +x configure
  18. }
  19. src_configure() {
  20. econf \
  21. --enable-search_libs \
  22. --enable-termcap \
  23. $(use_enable ncurses curses)
  24. }
  25. src_install() {
  26. default
  27. dodoc HINTS INFO LIST
  28. }