lpe-1.2.6.13.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib toolchain-funcs
  5. DESCRIPTION="a lightweight programmers editor"
  6. HOMEPAGE="http://packages.qa.debian.org/l/lpe.html"
  7. SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}-0.1.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc sparc x86 ~x86-linux"
  11. IUSE="nls"
  12. RDEPEND=">=sys-libs/slang-2.2.4
  13. >=sys-libs/ncurses-5.7-r7"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig
  16. nls? ( sys-devel/gettext )"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-make-382.patch
  19. # You should add PKG_CHECK_MODULES(NCURSES, ncurses) to configure.in and
  20. # replace -lncurses in src/Makefile.am with $(NCURSES_LIBS)
  21. # That is, if you need eautoreconf
  22. sed -i \
  23. -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs-only-l ncurses):" \
  24. src/Makefile.in || die
  25. }
  26. src_configure() {
  27. econf $(use_enable nls)
  28. }
  29. src_install() {
  30. emake \
  31. libdir="${ED}/usr/$(get_libdir)" \
  32. prefix="${ED}/usr" \
  33. datadir="${ED}/usr/share" \
  34. mandir="${ED}/usr/share/man" \
  35. infodir="${ED}/usr/share/info" \
  36. docdir="${ED}/usr/share/doc/${PF}" \
  37. exdir="${ED}/usr/share/doc/${PF}/examples" \
  38. install
  39. prune_libtool_files --all
  40. }