mousepad-0.4.0.ebuild 964 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit gnome2-utils xfconf
  5. DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
  6. HOMEPAGE="http://goodies.xfce.org/projects/applications/start"
  7. SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug dbus gtk3"
  12. RDEPEND=">=dev-libs/glib-2.30:2=
  13. dbus? ( >=dev-libs/dbus-glib-0.100:0= )
  14. !gtk3? ( >=x11-libs/gtk+-2.24:2=
  15. x11-libs/gtksourceview:2.0= )
  16. gtk3? ( x11-libs/gtk+:3=
  17. x11-libs/gtksourceview:3.0= )"
  18. DEPEND="${RDEPEND}
  19. dev-lang/perl
  20. dev-util/intltool
  21. sys-devel/gettext
  22. virtual/pkgconfig"
  23. pkg_setup() {
  24. XFCONF=(
  25. $(xfconf_use_debug)
  26. $(use_enable dbus)
  27. $(use_enable gtk3)
  28. )
  29. DOCS=( AUTHORS ChangeLog NEWS README TODO )
  30. }
  31. pkg_preinst() {
  32. xfconf_pkg_preinst
  33. gnome2_schemas_savelist
  34. }
  35. pkg_postinst() {
  36. xfconf_pkg_postinst
  37. gnome2_schemas_update
  38. }