sandy-0.4.ebuild 675 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic toolchain-funcs
  5. DESCRIPTION="an ncurses text editor with an easy-to-read, hackable C source"
  6. HOMEPAGE="http://tools.suckless.org/sandy"
  7. SRC_URI="http://git.suckless.org/${PN}/snapshot/${P}.tar.bz2"
  8. LICENSE="MIT-with-advertising"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. DEPEND="sys-libs/ncurses"
  12. RDEPEND="${DEPEND}"
  13. src_prepare() {
  14. epatch "${FILESDIR}"/${PN}-0.4-gentoo.patch
  15. }
  16. src_compile() {
  17. tc-export CC PKG_CONFIG
  18. append-cflags -D_DEFAULT_SOURCE
  19. emake PREFIX=/usr ${PN}
  20. }
  21. src_install() {
  22. emake PREFIX=/usr DESTDIR="${D}" install
  23. }