vile-9.8k.ebuild 976 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
  6. HOMEPAGE="http://invisible-island.net/vile/"
  7. SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  11. IUSE="perl"
  12. RDEPEND=">=sys-libs/ncurses-5.2
  13. perl? ( dev-lang/perl )"
  14. DEPEND="${RDEPEND}
  15. sys-devel/flex
  16. app-eselect/eselect-vi"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${PN}-9.8h-flex.patch
  19. }
  20. src_configure() {
  21. econf \
  22. --with-ncurses \
  23. $(use_with perl )
  24. }
  25. src_install() {
  26. emake DESTDIR="${D}" install
  27. dodoc CHANGES* README doc/*.doc
  28. dohtml doc/*.html
  29. }
  30. pkg_postinst() {
  31. einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
  32. eselect vi update --if-unset
  33. }
  34. pkg_postrm() {
  35. einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
  36. eselect vi update --if-unset
  37. }