vile-9.8n.ebuild 919 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
  5. HOMEPAGE="http://invisible-island.net/vile/"
  6. SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  10. IUSE="perl"
  11. RDEPEND=">=sys-libs/ncurses-5.2
  12. perl? ( dev-lang/perl )"
  13. DEPEND="${RDEPEND}
  14. sys-devel/flex
  15. app-eselect/eselect-vi"
  16. src_configure() {
  17. econf \
  18. --with-ncurses \
  19. $(use_with perl )
  20. }
  21. src_install() {
  22. emake DESTDIR="${D}" INSTALL_OPTS="" install
  23. dodoc CHANGES* README doc/*.doc
  24. dohtml doc/*.html
  25. }
  26. pkg_postinst() {
  27. einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
  28. eselect vi update --if-unset
  29. }
  30. pkg_postrm() {
  31. einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
  32. eselect vi update --if-unset
  33. }