vile-9.8s.ebuild 934 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
  5. HOMEPAGE="http://invisible-island.net/vile/"
  6. SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  10. IUSE="perl"
  11. RDEPEND=">=sys-libs/ncurses-5.2:0=
  12. perl? ( dev-lang/perl )"
  13. DEPEND="${RDEPEND}
  14. sys-devel/flex
  15. app-eselect/eselect-vi"
  16. src_configure() {
  17. econf \
  18. --with-ncurses \
  19. $(use_with perl )
  20. }
  21. src_install() {
  22. emake DESTDIR="${D}" INSTALL_OPT_S="" install
  23. dodoc CHANGES* README doc/*.doc
  24. docinto html
  25. dodoc doc/*.html
  26. }
  27. pkg_postinst() {
  28. einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
  29. eselect vi update --if-unset
  30. }
  31. pkg_postrm() {
  32. einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
  33. eselect vi update --if-unset
  34. }