xmlcopyeditor-1.2.1.3.ebuild 921 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. WX_GTK_VER="3.0"
  5. inherit autotools wxwidgets
  6. DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
  7. HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/xml-copy-editor/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
  12. IUSE="aqua nls"
  13. RDEPEND="
  14. app-text/aspell
  15. dev-libs/libxml2
  16. dev-libs/libxslt
  17. dev-libs/xerces-c[icu]
  18. dev-libs/libpcre
  19. !aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
  20. aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[aqua] )"
  21. DEPEND="${RDEPEND}
  22. dev-libs/boost
  23. dev-util/intltool"
  24. DOCS=( AUTHORS ChangeLog README NEWS )
  25. src_prepare() {
  26. # bug #440744
  27. sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
  28. eautoreconf
  29. need-wxwidgets unicode
  30. }
  31. src_configure() {
  32. econf $(use_enable nls)
  33. }