xvile-9.8n.ebuild 858 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. MY_P="${PN/x/}-${PV}"
  5. DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
  6. HOMEPAGE="http://invisible-island.net/vile/"
  7. SRC_URI="ftp://invisible-island.net/vile/current/${MY_P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
  11. IUSE="perl"
  12. RDEPEND="perl? ( dev-lang/perl )
  13. =app-editors/vile-${PV}
  14. >=x11-libs/libX11-1.0.0
  15. >=x11-libs/libXt-1.0.0
  16. >=x11-libs/libICE-1.0.0
  17. >=x11-libs/libSM-1.0.0
  18. >=x11-libs/libXaw-1.0.1
  19. >=x11-libs/libXpm-3.5.4.2
  20. >=x11-proto/xproto-7.0.4"
  21. DEPEND="${RDEPEND}
  22. sys-devel/flex"
  23. S=${WORKDIR}/${MY_P}
  24. src_configure() {
  25. econf \
  26. --with-ncurses \
  27. --with-x \
  28. $(use_with perl)
  29. }
  30. src_install() {
  31. dobin xvile
  32. dodoc CHANGES* README doc/*.doc
  33. dohtml doc/*.html
  34. }