yudit-2.9.6.ebuild 606 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Free (Y)unicode text editor for all unices"
  5. HOMEPAGE="http://www.yudit.org/"
  6. SRC_URI="http://yudit.org/download/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. RDEPEND="x11-libs/libX11"
  11. DEPEND="${RDEPEND}
  12. >=sys-devel/gettext-0.10"
  13. src_prepare() {
  14. #Don't strip binaries, let portage do that.
  15. sed -i "/^INSTALL_PROGRAM/s: -s::" Makefile.conf.in || die "sed failed"
  16. }
  17. src_install() {
  18. emake DESTDIR="${D}" install
  19. dodoc {BUGS,CHANGELOG,NEWS,TODO,XBUGS}.TXT
  20. }