zile-2.4.11.ebuild 901 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Zile is a small Emacs clone"
  5. HOMEPAGE="https://www.gnu.org/software/zile/"
  6. SRC_URI="mirror://gnu/zile/${P}.tar.gz"
  7. LICENSE="GPL-3+"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
  10. IUSE="acl test"
  11. RDEPEND=">=dev-libs/boehm-gc-7.2
  12. sys-libs/ncurses:0
  13. acl? ( virtual/acl )"
  14. DEPEND="${RDEPEND}
  15. test? ( dev-lang/perl )"
  16. QA_AM_MAINTAINER_MODE=".*help2man.*" #450278
  17. src_configure() {
  18. econf \
  19. --docdir="${EPREFIX}"/usr/share/doc/${PF} \
  20. $(use_enable acl)
  21. }
  22. src_install() {
  23. emake DESTDIR="${D}" install
  24. # AUTHORS, FAQ, and NEWS are installed by the build system
  25. dodoc README THANKS
  26. # Zile should never install charset.alias (even on non-glibc arches)
  27. rm -f "${ED}"/usr/lib/charset.alias
  28. }