cycle-buffer-2.16.ebuild 521 B

1234567891011121314151617181920212223
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit elisp
  5. DESCRIPTION="Select buffer by cycling through"
  6. HOMEPAGE="http://www.emacswiki.org/emacs/cycle-buffer.el"
  7. # taken from https://www.emacswiki.org/emacs/download/cycle-buffer.el
  8. SRC_URI="https://enise.org/users/victor/share/distfiles/${P}.el.xz"
  9. LICENSE="public-domain"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. SITEFILE="50${PN}-gentoo.el"
  13. src_compile() {
  14. elisp-compile *.el
  15. elisp-make-autoload-file
  16. }