desktop+-0.2.ebuild 575 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit elisp
  5. DESCRIPTION="desktop+ extends standard desktop module"
  6. HOMEPAGE="https://github.com/ffevotte/desktop-plus"
  7. SRC_URI="https://github.com/ffevotte/desktop-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3+"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. RDEPEND="app-emacs/dash app-emacs/f"
  12. DEPEND="${RDEPEND}"
  13. S="${WORKDIR}/desktop-plus-${PV}"
  14. SITEFILE="50${PN}-gentoo.el"
  15. DOCS="README.md"
  16. src_compile() {
  17. elisp-compile *.el
  18. elisp-make-autoload-file
  19. }