editorconfig-emacs-0.7.8.ebuild 601 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit elisp
  5. DESCRIPTION="EditorConfig plugin for emacs"
  6. HOMEPAGE="https://github.com/editorconfig/${PN}/"
  7. SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RESTRICT="test"
  13. src_install() {
  14. local site_file="${T}/50${PN}-gentoo.el"
  15. echo "
  16. (require 'editorconfig)
  17. (editorconfig-mode 1)
  18. " > "${site_file}" || die
  19. elisp-site-file-install "${site_file}"
  20. elisp_src_install
  21. dodoc README.md
  22. }