gnuserv-3.12.8-r2.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit elisp multilib fdo-mime
  5. DESCRIPTION="Attach to an already running Emacs"
  6. HOMEPAGE="http://meltin.net/hacks/emacs/"
  7. SRC_URI="http://meltin.net/hacks/emacs/src/${P}.tar.gz"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86 ~x86-linux ~ppc-macos"
  11. IUSE="X"
  12. DEPEND=">=app-eselect/eselect-emacs-1.15
  13. X? ( x11-libs/libXau )"
  14. RDEPEND="${DEPEND}
  15. !!app-emacs/gnuserv-programs
  16. !!<app-editors/xemacs-21.4.22-r3
  17. !!~app-editors/xemacs-21.5.29 !!~app-editors/xemacs-21.5.30
  18. !!~app-editors/xemacs-21.5.31 !!~app-editors/xemacs-21.5.33
  19. !!=app-editors/xemacs-21.5.34 !!=app-editors/xemacs-21.5.34-r1"
  20. SITEFILE="50${PN}-gentoo.el"
  21. src_prepare() {
  22. sed -i -e 's/exec gnuclient/&-emacs/' gnudoit || die
  23. }
  24. src_configure() {
  25. econf $(use_enable X xauth) \
  26. --x-includes="${EPREFIX}"/usr/include \
  27. --x-libraries="${EPREFIX}"/usr/$(get_libdir)
  28. }
  29. src_compile() {
  30. default
  31. }
  32. src_install() {
  33. exeinto /usr/libexec/emacs
  34. doexe gnuserv
  35. newbin gnuclient gnuclient-emacs
  36. newbin gnudoit gnudoit-emacs
  37. # Don't install gnuattach, it is not functional with FSF GNU Emacs
  38. newman gnuserv.1 gnuserv-emacs.1
  39. echo ".so man1/gnuserv-emacs.1" | newman - gnuclient-emacs.1
  40. echo ".so man1/gnuserv-emacs.1" | newman - gnudoit-emacs.1
  41. elisp-install ${PN} *.el *.elc
  42. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  43. dodoc ChangeLog README README.orig
  44. if use X; then
  45. domenu "${FILESDIR}"/gnuclient.desktop || die
  46. fi
  47. }
  48. pkg_postinst() {
  49. elisp-site-regen
  50. use X && fdo-mime_desktop_database_update
  51. eselect gnuclient update ifunset
  52. }
  53. pkg_postrm() {
  54. elisp-site-regen
  55. use X && fdo-mime_desktop_database_update
  56. eselect gnuclient update ifunset
  57. }