mpg123-el-1.59.ebuild 837 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit elisp toolchain-funcs
  5. DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
  6. HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
  7. SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
  8. LICENSE="mpg123-el"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. RDEPEND="media-sound/mpg123
  12. media-sound/alsa-utils"
  13. SITEFILE="50${PN}-gentoo.el"
  14. src_prepare() {
  15. sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
  16. }
  17. src_compile() {
  18. $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tagput tagput.c || die
  19. $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o id3put id3put.c || die
  20. elisp-compile *.el
  21. }
  22. src_install() {
  23. dobin tagput id3put
  24. elisp-install ${PN} *.el *.elc
  25. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  26. }