mpg123-el-1.60.ebuild 794 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit elisp toolchain-funcs
  5. DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
  6. HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
  7. SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
  8. LICENSE="mpg123-el"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. RDEPEND="media-sound/mpg123
  12. media-sound/alsa-utils"
  13. SITEFILE="50${PN}-gentoo.el"
  14. src_compile() {
  15. $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o tagput tagput.c || die
  16. $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o id3put id3put.c || die
  17. elisp-compile *.el
  18. }
  19. src_install() {
  20. dobin tagput id3put
  21. elisp-install ${PN} *.el *.elc
  22. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  23. }