nxml-docbook5-schemas-20080922.ebuild 586 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit elisp
  5. DESCRIPTION="Add support for DocBook 5 schemas to NXML"
  6. HOMEPAGE="http://www.docbook.org/schemas/5x.html"
  7. SRC_URI="http://www.docbook.org/xml/5.0/rng/docbookxi.rnc"
  8. LICENSE="HPND"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. S="${WORKDIR}"
  12. SITEFILE="60${PN}-gentoo.el"
  13. src_unpack() { :; }
  14. src_compile() { :; }
  15. src_install() {
  16. insinto ${SITEETC}/${PN}
  17. doins "${FILESDIR}"/schemas.xml "${DISTDIR}"/docbookxi.rnc
  18. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  19. }