sml-mode-6.1-r1.ebuild 527 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit elisp
  5. DESCRIPTION="Emacs major mode for editing Standard ML"
  6. HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
  7. # taken from http://bzr.sv.gnu.org/r/emacs/elpa
  8. SRC_URI="mirror://gentoo/${P}.el.xz"
  9. LICENSE="GPL-3+"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 ppc x86"
  12. DEPEND="app-arch/xz-utils"
  13. SITEFILE="50${PN}-gentoo-${PV}.el"
  14. src_compile() {
  15. elisp-compile *.el || die
  16. elisp-make-autoload-file || die
  17. }