sml-mode-6.4.ebuild 500 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. NEED_EMACS=24
  5. inherit elisp
  6. DESCRIPTION="Emacs major mode for editing Standard ML"
  7. HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
  8. # taken from https://elpa.gnu.org/packages/${P}.el
  9. SRC_URI="mirror://gentoo/${P}.el.xz"
  10. LICENSE="GPL-3+"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 ppc x86"
  13. SITEFILE="50${PN}-gentoo-6.1.el"
  14. src_compile() {
  15. elisp-compile *.el
  16. elisp-make-autoload-file
  17. }