sumibi-0.5.2.ebuild 709 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit elisp
  4. DESCRIPTION="Statistical Japanese input method using the Internet as a large corpus"
  5. HOMEPAGE="http://www.sumibi.org/"
  6. SRC_URI="mirror://sourceforge.jp/sumibi/17176/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE=""
  11. SITEFILE=50${PN}-gentoo.el
  12. src_compile() {
  13. cd client/elisp
  14. elisp-compile *.el || die "elisp-compile failed"
  15. }
  16. src_install() {
  17. cd client/elisp
  18. elisp-install ${PN} *.{el,elc} || die "elisp-install failed"
  19. elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
  20. || die "elisp-site-file-install failed"
  21. cd "${S}"
  22. dodoc README CREDITS CHANGELOG
  23. }