template-3.1c-r1.ebuild 637 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit elisp
  5. DESCRIPTION="Use templates, decorate comments, auto-update buffers"
  6. HOMEPAGE="http://emacs-template.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/emacs-template/${P}.tar.gz"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. S="${WORKDIR}/${PN}"
  12. SITEFILE="50${PN}-gentoo.el"
  13. src_compile() {
  14. elisp-compile lisp/*.el
  15. }
  16. src_install() {
  17. elisp-install ${PN} lisp/*.{el,elc}
  18. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  19. insinto "${SITEETC}/${PN}"
  20. doins -r templates
  21. dodoc README lisp/ChangeLog
  22. }