docker-machine-0.9.0.ebuild 904 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. EGO_PN=github.com/docker/machine/...
  5. if [[ ${PV} = *9999* ]]; then
  6. inherit golang-vcs
  7. else
  8. KEYWORDS="~amd64"
  9. EGIT_COMMIT="v${PV}"
  10. SRC_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
  11. inherit golang-vcs-snapshot
  12. fi
  13. inherit golang-build
  14. DESCRIPTION="Machine management for a container-centric world"
  15. HOMEPAGE="https://docs.docker.com/machine/"
  16. LICENSE="Apache-2.0"
  17. SLOT="0"
  18. IUSE=""
  19. RESTRICT="test"
  20. DEPEND=">=dev-lang/go-1.7:="
  21. RDEPEND=""
  22. S=${WORKDIR}/${P}/src/${EGO_PN%/*}
  23. src_prepare() {
  24. eapply_user
  25. # don't pre-strip binaries
  26. sed -e 's|\(GO_LDFLAGS := $(GO_LDFLAGS) -w\) -s|\1|' -i mk/main.mk ||die
  27. }
  28. src_compile() {
  29. GOPATH="${WORKDIR}/${P}" emake build || die
  30. }
  31. src_install() {
  32. dobin bin/*
  33. dodoc CHANGELOG.md CONTRIBUTING.md README.md ROADMAP.md
  34. }