docker-proxy-9999.ebuild 766 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. EGO_PN="github.com/docker/libnetwork"
  5. if [[ ${PV} == *9999 ]]; then
  6. inherit golang-vcs
  7. else
  8. EGIT_COMMIT=""
  9. SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64 ~ppc64"
  11. inherit golang-vcs-snapshot
  12. fi
  13. DESCRIPTION="Docker container networking"
  14. HOMEPAGE="http://github.com/docker/libnetwork"
  15. LICENSE="Apache-2.0"
  16. SLOT="0"
  17. IUSE=""
  18. S=${WORKDIR}/${P}/src/${EGO_PN}
  19. RDEPEND="!<app-emulation/docker-1.13.0_rc1"
  20. src_compile() {
  21. GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -o "bin/docker-proxy" ./cmd/proxy || die
  22. }
  23. src_install() {
  24. dodoc ROADMAP.md README.md CHANGELOG.md
  25. dobin bin/docker-proxy
  26. }