virt-viewer-4.0.ebuild 913 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="Graphical console client for connecting to virtual machines"
  6. HOMEPAGE="http://virt-manager.org/"
  7. SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="sasl +spice +vnc"
  12. RDEPEND=">=app-emulation/libvirt-0.10.0[sasl?]
  13. app-emulation/libvirt-glib
  14. >=dev-libs/libxml2-2.6
  15. x11-libs/gtk+:3
  16. spice? ( >=net-misc/spice-gtk-0.31[sasl?,gtk3] )
  17. vnc? ( >=net-libs/gtk-vnc-0.5.0[sasl?,gtk3] )"
  18. DEPEND="${RDEPEND}
  19. dev-lang/perl
  20. >=dev-util/intltool-0.35.0
  21. virtual/pkgconfig
  22. spice? ( >=app-emulation/spice-protocol-0.12.10 )"
  23. REQUIRED_USE="|| ( spice vnc )"
  24. src_configure() {
  25. gnome2_src_configure \
  26. --disable-update-mimedb \
  27. --without-ovirt \
  28. $(use_with vnc gtk-vnc) \
  29. $(use_with spice spice-gtk)
  30. }