foremost-1.5.7-r1.ebuild 791 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="A console program to recover files based on their headers and footers"
  6. HOMEPAGE="http://foremost.sourceforge.net/"
  7. #SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. # starting to hate sf.net ...
  9. SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. LICENSE="public-domain"
  13. SLOT="0"
  14. src_prepare() {
  15. epatch "${FILESDIR}/${PN}-1.4-config-location.patch"
  16. }
  17. src_compile() {
  18. emake RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
  19. CONF=/etc
  20. }
  21. src_install() {
  22. dobin foremost
  23. doman foremost.8.gz
  24. insinto /etc
  25. doins foremost.conf
  26. dodoc README CHANGES
  27. }