libewf-20130416-r1.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils
  5. DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
  6. HOMEPAGE="https://github.com/libyal/libewf"
  7. SRC_URI="https://libewf.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0/2"
  10. KEYWORDS="~amd64 ~hppa ~ppc ~x86"
  11. # upstream bug #2597171, pyewf has implicit declarations
  12. #IUSE="debug python rawio unicode"
  13. IUSE="bfio debug ewf +fuse rawio +ssl static-libs +uuid unicode zlib"
  14. DEPEND="
  15. sys-libs/zlib
  16. bfio? ( =app-forensics/libbfio-0.0.20120425_alpha )
  17. fuse? ( sys-fs/fuse )
  18. uuid? ( sys-apps/util-linux )
  19. ssl? ( dev-libs/openssl )
  20. zlib? ( sys-libs/zlib )"
  21. RDEPEND="${DEPEND}"
  22. AUTOTOOLS_IN_SOURCE_BUILD=1
  23. DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
  24. src_configure() {
  25. local myeconfargs=(
  26. $(use_enable debug debug-output)
  27. $(use_enable debug verbose-output)
  28. $(use_enable ewf v1-api)
  29. $(use_enable rawio low-level-functions)
  30. $(use_enable unicode wide-character-type)
  31. $(use_with zlib)
  32. # autodetects bzip2 but does not use
  33. --without-bzip2
  34. $(use_with bfio libbfio)
  35. $(use_with ssl openssl)
  36. $(use_with uuid libuuid)
  37. $(use_with fuse libfuse)
  38. )
  39. autotools-utils_src_configure
  40. }
  41. src_install() {
  42. autotools-utils_src_install
  43. doman manuals/*.1 manuals/*.3
  44. }