libewf-20140227.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils
  5. DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
  6. HOMEPAGE="https://github.com/libyal/libewf"
  7. SRC_URI="https://googledrive.com/host/0B3fBvzttpiiSMTdoaVExWWNsRjg/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0/2"
  10. KEYWORDS="~amd64 ~hppa ~ppc ~x86"
  11. # upstream bug #2597171, pyewf has implicit declarations
  12. #IUSE="debug python unicode"
  13. IUSE="bfio debug ewf +fuse +ssl static-libs +uuid unicode zlib"
  14. DEPEND="
  15. sys-libs/zlib
  16. bfio? ( =app-forensics/libbfio-0.0.20120425_alpha )
  17. fuse? ( sys-fs/fuse )
  18. uuid? ( sys-apps/util-linux )
  19. ssl? ( dev-libs/openssl )
  20. zlib? ( sys-libs/zlib )"
  21. RDEPEND="${DEPEND}"
  22. AUTOTOOLS_IN_SOURCE_BUILD=1
  23. DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
  24. src_configure() {
  25. local myeconfargs=(
  26. $(use_enable debug debug-output)
  27. $(use_enable debug verbose-output)
  28. $(use_enable ewf v1-api)
  29. $(use_enable unicode wide-character-type)
  30. $(use_with zlib)
  31. # autodetects bzip2 but does not use
  32. --without-bzip2
  33. $(use_with bfio libbfio)
  34. $(use_with ssl openssl)
  35. $(use_with uuid libuuid)
  36. $(use_with fuse libfuse)
  37. )
  38. autotools-utils_src_configure
  39. }
  40. src_install() {
  41. autotools-utils_src_install
  42. doman manuals/*.1 manuals/*.3
  43. }