bidiv-1.5_p4.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. PATCH_LEVEL=4
  6. DESCRIPTION="A commandline tool displaying logical Hebrew/Arabic"
  7. HOMEPAGE="http://packages.qa.debian.org/b/bidiv.html"
  8. SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig.tar.gz
  9. mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PATCH_LEVEL}.debian.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
  13. IUSE=""
  14. RDEPEND=">=dev-libs/fribidi-0.19.2-r2"
  15. DEPEND="${DEPEND}
  16. virtual/pkgconfig"
  17. S=${WORKDIR}/${PN}
  18. src_prepare() {
  19. # Use order from "series" file:
  20. local ddir=${WORKDIR}/debian/patches
  21. epatch \
  22. "${ddir}"/try_utf8_fix \
  23. "${ddir}"/makefile \
  24. "${ddir}"/fribidi_019 \
  25. "${ddir}"/hyphen_minus \
  26. "${ddir}"/term_size_get \
  27. "${ddir}"/type_fix \
  28. "${ddir}"/cast_fix
  29. }
  30. src_compile() {
  31. tc-export CC
  32. emake CC_OPT_FLAGS="-Wall"
  33. }
  34. src_install() {
  35. dobin ${PN}
  36. doman ${PN}.1
  37. dodoc README WHATSNEW "${WORKDIR}"/debian/changelog
  38. }