fbiterm-0.5-r2.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools-utils eutils multilib
  5. IUSE=""
  6. DESCRIPTION="Framebuffer internationalized terminal emulator"
  7. HOMEPAGE="http://www-124.ibm.com/linux/projects/iterm/"
  8. SRC_URI="http://www-124.ibm.com/linux/projects/iterm/releases/iterm-${PV}.tar.gz"
  9. LICENSE="CPL-0.5"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. DEPEND="x11-libs/libXfont
  13. >=media-libs/freetype-2
  14. x11-libs/libiterm-mbt
  15. sys-libs/zlib"
  16. RDEPEND="${DEPEND}
  17. media-fonts/font-sony-misc
  18. media-fonts/unifont"
  19. PATCHES=(
  20. "${FILESDIR}"/${PF}-gentoo.diff
  21. "${FILESDIR}"/${P}-cflags.patch
  22. )
  23. DOCS=( AUTHORS ChangeLog README{,.jp,.zh_CN} )
  24. AUTOTOOLS_AUTORECONF=1
  25. S="${WORKDIR}/iterm/unix/fbiterm"
  26. src_configure() {
  27. local myeconfargs=(
  28. --x-includes=/usr/include
  29. --x-libraries=/usr/$(get_libdir)
  30. )
  31. autotools-utils_src_configure
  32. }
  33. pkg_postinst() {
  34. elog
  35. elog "1. If you haven't created your locale, run localedef."
  36. elog "# localedef -v -c -i en_GB -f UTF-8 en_GB.UTF-8"
  37. elog "(If you want to use other locales such as Japanese, replace"
  38. elog "en_GB with ja_JP and en_GB.UTF-8 with ja_JP.UTF-8, respectively)"
  39. elog
  40. elog "2. Set enviroment variable."
  41. elog "% export LC_CTYPE=en_GB.UTF-8 (sh, bash, zsh, ...)"
  42. elog "> setenv LC_CTYPE en_GB.UTF-8 (csh, tcsh, ...)"
  43. elog "(Again, if you want to use Japanese locale, create ja_JP.UTF-8"
  44. elog " locale by localedef and set LC_CTYPE to ja_JP.UTF-8)"
  45. elog
  46. elog "3. Run unicode_start."
  47. elog "% unicode_start"
  48. elog
  49. elog "4. Run fbiterm."
  50. elog "% fbiterm"
  51. elog
  52. }