fbterm-1.7-r1.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit autotools-utils
  5. DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
  6. HOMEPAGE="https://fbterm.googlecode.com/"
  7. SRC_URI="https://fbterm.googlecode.com/files/${P}.0.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  11. IUSE="caps gpm video_cards_vesa"
  12. RDEPEND="caps? ( sys-libs/libcap )
  13. gpm? ( sys-libs/gpm )
  14. video_cards_vesa? ( dev-libs/libx86 )
  15. media-libs/fontconfig
  16. media-libs/freetype:2"
  17. DEPEND="${RDEPEND}
  18. sys-libs/ncurses
  19. virtual/pkgconfig"
  20. AUTOTOOLS_IN_SOURCE_BUILD=1
  21. DOCS=( AUTHORS NEWS README )
  22. src_configure() {
  23. local myeconfargs=(
  24. $(use_enable gpm)
  25. $(use_enable video_cards_vesa vesa)
  26. )
  27. autotools-utils_src_configure
  28. }
  29. src_install() {
  30. autotools-utils_src_install
  31. $(type -P tic) -o "${ED}/usr/share/terminfo/" \
  32. "${S}"/terminfo/fbterm || die "Failed to generate terminfo database"
  33. if use caps; then
  34. setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/fbterm
  35. else
  36. fperms u+s /usr/bin/fbterm
  37. fi
  38. }
  39. pkg_postinst() {
  40. einfo
  41. einfo " ${PN} won't work with vga16fb. You have to use other native"
  42. einfo " framebuffer drivers or vesa driver."
  43. einfo " See ${EPREFIX}/usr/share/doc/${P}/README for details."
  44. einfo " To use ${PN}, ensure you are in video group."
  45. einfo " To input CJK merge app-i18n/fbterm-ucimf"
  46. einfo
  47. }