12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- inherit autotools-utils
- DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
- HOMEPAGE="https://fbterm.googlecode.com/"
- SRC_URI="https://fbterm.googlecode.com/files/${P}.0.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
- IUSE="caps gpm video_cards_vesa"
- RDEPEND="caps? ( sys-libs/libcap )
- gpm? ( sys-libs/gpm )
- video_cards_vesa? ( dev-libs/libx86 )
- media-libs/fontconfig
- media-libs/freetype:2"
- DEPEND="${RDEPEND}
- sys-libs/ncurses
- virtual/pkgconfig"
- AUTOTOOLS_IN_SOURCE_BUILD=1
- DOCS=( AUTHORS NEWS README )
- PATCHES=(
- "${FILESDIR}"/${P}-gcc6.patch
- )
- src_configure() {
- local myeconfargs=(
- $(use_enable gpm)
- $(use_enable video_cards_vesa vesa)
- )
- autotools-utils_src_configure
- }
- src_install() {
- autotools-utils_src_install
- $(type -P tic) -o "${ED}/usr/share/terminfo/" \
- "${S}"/terminfo/fbterm || die "Failed to generate terminfo database"
- if use caps; then
- setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/fbterm
- else
- fperms u+s /usr/bin/fbterm
- fi
- }
- pkg_postinst() {
- einfo
- einfo " ${PN} won't work with vga16fb. You have to use other native"
- einfo " framebuffer drivers or vesa driver."
- einfo " See ${EPREFIX}/usr/share/doc/${P}/README for details."
- einfo " To use ${PN}, ensure you are in video group."
- einfo " To input CJK merge app-i18n/fbterm-ucimf"
- einfo
- }
|