fcitx-libpinyin-0.3.1.ebuild 797 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils gnome2-utils
  5. DESCRIPTION="Libpinyin module for Fcitx"
  6. HOMEPAGE="http://fcitx-im.org/"
  7. SRC_URI="http://download.fcitx-im.org/${PN}/${P}_dict.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc ppc64 ~x86"
  11. IUSE="dictmanager"
  12. RDEPEND=">=app-i18n/fcitx-4.2.8
  13. <app-i18n/libpinyin-1.3.0
  14. dev-libs/glib:2
  15. dictmanager? ( >=app-i18n/fcitx-4.2.8[qt4]
  16. dev-qt/qtcore:4
  17. dev-qt/qtgui:4
  18. dev-qt/qtwebkit:4 )"
  19. DEPEND="${RDEPEND}
  20. virtual/libintl
  21. virtual/pkgconfig"
  22. src_configure() {
  23. local mycmakeargs="$(cmake-utils_use_enable dictmanager QT)"
  24. cmake-utils_src_configure
  25. }
  26. pkg_postinst() {
  27. gnome2_icon_cache_update
  28. }
  29. pkg_postrm() {
  30. gnome2_icon_cache_update
  31. }