fcitx-m17n-9999.ebuild 647 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit cmake-utils
  5. if [[ "${PV}" == "9999" ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/fcitx/fcitx-m17n"
  8. fi
  9. DESCRIPTION="m17n-provided input methods for Fcitx"
  10. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-m17n"
  11. if [[ "${PV}" == "9999" ]]; then
  12. SRC_URI=""
  13. else
  14. SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
  15. fi
  16. LICENSE="LGPL-2.1+"
  17. SLOT="0"
  18. KEYWORDS=""
  19. IUSE=""
  20. RDEPEND=">=app-i18n/fcitx-4.2.8
  21. dev-libs/m17n-lib
  22. virtual/libintl"
  23. DEPEND="${RDEPEND}
  24. virtual/pkgconfig"
  25. DOCS=()