fcitx-qt5-1.0.5.ebuild 860 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit cmake-utils
  5. if [[ "${PV}" == "9999" ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/fcitx/fcitx-qt5"
  8. fi
  9. DESCRIPTION="Fcitx input method module for Qt 5"
  10. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-qt5"
  11. if [[ "${PV}" == "9999" ]]; then
  12. SRC_URI=""
  13. else
  14. SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
  15. fi
  16. LICENSE="GPL-2+"
  17. SLOT="0"
  18. KEYWORDS="amd64 ~hppa ~ppc64 x86"
  19. IUSE=""
  20. # Private headers of dev-qt/qtgui:5 used.
  21. RDEPEND=">=app-i18n/fcitx-4.2.8
  22. dev-qt/qtcore:5
  23. dev-qt/qtdbus:5
  24. dev-qt/qtgui:5=
  25. dev-qt/qtwidgets:5
  26. virtual/libintl
  27. x11-libs/libxkbcommon"
  28. DEPEND="${RDEPEND}
  29. kde-frameworks/extra-cmake-modules:5
  30. virtual/pkgconfig"
  31. PATCHES=(
  32. "${FILESDIR}/${P}-ucs4.patch"
  33. )
  34. DOCS=()