fcitx-unikey-0.2.0.ebuild 763 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils gnome2-utils
  5. DESCRIPTION="Vietnamese Unikey module for Fcitx"
  6. HOMEPAGE="http://fcitx-im.org/"
  7. SRC_URI="https://fcitx.googlecode.com/files/${P}.tar.xz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ~ppc64 x86"
  11. IUSE="+qt4"
  12. RDEPEND=">=app-i18n/fcitx-4.2.7[qt4?]"
  13. DEPEND="${RDEPEND}
  14. sys-devel/gettext"
  15. src_prepare() {
  16. # Add cmake option to build the qt based macro editor or not
  17. epatch "${FILESDIR}/${P}-cmake-qt-option.patch"
  18. }
  19. src_configure() {
  20. local mycmakeargs=(
  21. $(cmake-utils_use_enable qt4 QT)
  22. )
  23. cmake-utils_src_configure
  24. }
  25. pkg_postinst() {
  26. gnome2_icon_cache_update
  27. }
  28. pkg_postrm() {
  29. gnome2_icon_cache_update
  30. }