fcitx-unikey-0.2.4.ebuild 634 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils gnome2-utils
  5. DESCRIPTION="Vietnamese Unikey module for Fcitx"
  6. HOMEPAGE="http://fcitx-im.org/"
  7. SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc ppc64 ~x86"
  11. IUSE="+qt4"
  12. RDEPEND=">=app-i18n/fcitx-4.2.8[qt4?]"
  13. DEPEND="${RDEPEND}
  14. sys-devel/gettext"
  15. src_configure() {
  16. local mycmakeargs=(
  17. $(cmake-utils_use_enable qt4 QT)
  18. )
  19. cmake-utils_src_configure
  20. }
  21. pkg_postinst() {
  22. gnome2_icon_cache_update
  23. }
  24. pkg_postrm() {
  25. gnome2_icon_cache_update
  26. }