fcitx-unikey-0.2.5.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit cmake-utils gnome2-utils
  5. if [[ "${PV}" == "9999" ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/fcitx/fcitx-unikey"
  8. fi
  9. DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
  10. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-unikey"
  11. if [[ "${PV}" == "9999" ]]; then
  12. SRC_URI=""
  13. else
  14. SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
  15. fi
  16. LICENSE="GPL-2+ GPL-3+"
  17. SLOT="0"
  18. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  19. IUSE="+macro-editor"
  20. RDEPEND=">=app-i18n/fcitx-4.2.8
  21. virtual/libiconv
  22. virtual/libintl
  23. macro-editor? (
  24. >=app-i18n/fcitx-4.2.8[qt4]
  25. dev-qt/qtcore:4
  26. dev-qt/qtgui:4
  27. )"
  28. DEPEND="${RDEPEND}
  29. sys-devel/gettext
  30. virtual/pkgconfig"
  31. PATCHES=(
  32. "${FILESDIR}/${P}-c++11.patch"
  33. )
  34. DOCS=()
  35. src_configure() {
  36. local mycmakeargs=(
  37. -DENABLE_QT=$(usex macro-editor)
  38. )
  39. cmake-utils_src_configure
  40. }
  41. pkg_preinst() {
  42. gnome2_icon_savelist
  43. }
  44. pkg_postinst() {
  45. gnome2_icon_cache_update
  46. }
  47. pkg_postrm() {
  48. gnome2_icon_cache_update
  49. }