fcitx-unikey-9999.ebuild 1009 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit cmake-utils gnome2-utils
  5. if [[ "${PV}" == "9999" ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/fcitx/fcitx-unikey"
  8. fi
  9. DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
  10. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-unikey"
  11. if [[ "${PV}" == "9999" ]]; then
  12. SRC_URI=""
  13. else
  14. SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
  15. fi
  16. LICENSE="GPL-2+ GPL-3+"
  17. SLOT="0"
  18. KEYWORDS=""
  19. IUSE="+macro-editor"
  20. RDEPEND=">=app-i18n/fcitx-4.2.8
  21. virtual/libintl
  22. macro-editor? (
  23. >=app-i18n/fcitx-4.2.8[qt4]
  24. dev-qt/qtcore:4
  25. dev-qt/qtgui:4
  26. )"
  27. DEPEND="${RDEPEND}
  28. sys-devel/gettext
  29. virtual/pkgconfig"
  30. DOCS=()
  31. src_configure() {
  32. local mycmakeargs=(
  33. -DENABLE_QT=$(usex macro-editor)
  34. )
  35. cmake-utils_src_configure
  36. }
  37. pkg_preinst() {
  38. gnome2_icon_savelist
  39. }
  40. pkg_postinst() {
  41. gnome2_icon_cache_update
  42. }
  43. pkg_postrm() {
  44. gnome2_icon_cache_update
  45. }