ibus-anthy-1.5.4.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-single-r1 autotools gnome2-utils
  6. DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
  7. HOMEPAGE="https://github.com/ibus/ibus/wiki"
  8. SRC_URI="https://ibus.googlecode.com/files/${P}.tar.gz
  9. https://raw.github.com/ibus/ibus-anthy/${PV}/engine/anthy.i"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~ppc x86"
  13. IUSE="deprecated nls"
  14. RDEPEND="${PYTHON_DEPS}
  15. >=app-i18n/ibus-1.5.0
  16. app-i18n/anthy
  17. deprecated? ( >=dev-python/pygtk-2.15.2 )
  18. nls? ( virtual/libintl )"
  19. DEPEND="${RDEPEND}
  20. dev-libs/gobject-introspection
  21. dev-util/intltool
  22. virtual/pkgconfig
  23. deprecated? ( dev-lang/swig )
  24. nls? ( >=sys-devel/gettext-0.16.1 )"
  25. src_prepare() {
  26. >py-compile #397497
  27. cp "${DISTDIR}"/anthy.i "${S}"/engine # deal with packaging bug
  28. }
  29. src_configure() {
  30. econf --enable-private-png \
  31. $(use_enable deprecated pygtk2-anthy) \
  32. $(use_enable nls)
  33. }
  34. src_install() {
  35. emake DESTDIR="${D}" install
  36. dodoc AUTHORS ChangeLog NEWS README
  37. find "${ED}" -name '*.la' -type f -delete || die
  38. python_optimize
  39. }
  40. pkg_preinst() {
  41. gnome2_icon_savelist
  42. }
  43. pkg_postinst() {
  44. elog
  45. elog "app-dicts/kasumi is not required but probably useful for you."
  46. elog
  47. elog "# emerge app-dicts/kasumi"
  48. elog
  49. }
  50. pkg_postrm() {
  51. gnome2_icon_cache_update
  52. }