ibus-anthy-1.5.9.ebuild 1019 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit gnome2-utils python-single-r1
  6. DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
  7. HOMEPAGE="https://github.com/ibus/ibus/wiki"
  8. SRC_URI="https://github.com/ibus/ibus-anthy/releases/download/${PV}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE="nls"
  13. RDEPEND="${PYTHON_DEPS}
  14. app-i18n/anthy
  15. app-i18n/ibus[introspection]
  16. nls? ( virtual/libintl:0= )"
  17. DEPEND="${RDEPEND}
  18. dev-libs/gobject-introspection
  19. dev-util/intltool
  20. virtual/pkgconfig
  21. nls? ( sys-devel/gettext )"
  22. src_configure() {
  23. econf \
  24. --enable-private-png \
  25. $(use_enable nls)
  26. }
  27. src_install() {
  28. default
  29. find "${ED}" -name '*.la' -type f -delete || die
  30. }
  31. pkg_preinst() {
  32. gnome2_icon_savelist
  33. }
  34. pkg_postinst() {
  35. elog "app-dicts/kasumi is not required but probably useful for you."
  36. gnome2_icon_cache_update
  37. }
  38. pkg_postrm() {
  39. gnome2_icon_cache_update
  40. }